Dieser Artikel richtet sich an Unternehmen mit einem Dashlane-Business-Tarif.
Auf Dashlane Business upgraden
In diesem Artikel werden Fehler, die bei der Einrichtung der SSO-Verbindung auftreten können, sowie mögliche Lösungen beschrieben.
Ungültige SAML-Signatur
Fehler:
Die SAML-Assertion des Identitätsanbieters weist eine ungültige Signatur auf. Wenn Sie der Administrator sind, achten Sie bitte darauf, die SSO-Verbindung so zu konfigurieren, dass sie das richtige SAML-Zertifikat für den Identitätsanbieter verwendet.
Ursache:
Die Identitätsanbieter-Metadaten und die SSO-Verbindungsvariable DASHLANE_SSO_SAML_IDP_CERTIFICATE stimmen nicht überein.
Manchmal wird dies durch das Öffnen der XML-Datei in IE verursacht, was beim Kopieren der Seite in IE zu überflüssigen Daten führen kann.
Lösung:
- Laden Sie die XML-Metadaten erneut von Ihrem Identitätsanbieter herunter.
- Öffnen Sie die XML-Datei mit Notepad oder einem anderen Klartexteditor-Programm.
- Fügen Sie die XML-Daten in die Dashlane-Konsole ein.
https://console.dashlane.com > Einstellungen > SAML-SSO > Metadaten des Identitätsanbieters
- Sie werden nicht den neu generierten Schlüssel verwenden, sondern müssen auf Schlüssel generieren klicken, um die Konfigurationsdatei herunterzuladen.
- Laden Sie die Konfigurationsdatei in der Dashlane-Konsole herunter.
- Gehen Sie auf portal.azure.com zu der von Ihnen erstellten Azure-App. Fügen Sie in der Konfiguration erneut die Variable DASHLANE_SSO_SAML_IDP_CERTIFICATE= aus der Konfigurationsdatei, die Sie gerade heruntergeladen haben, in die entsprechenden Werte in Azure ein.
- Klicken Sie auf Speichern.
- Starten Sie den App-Dienst neu.
- Führen Sie den Test über die Dashlane-Konsole erneut aus. Sie sollten folgende Nachricht angezeigt bekommen:
Anwendung mit Kennung wurde im Verzeichnis nicht gefunden
Fehler:
Anwendung mit Kennung wurde im Verzeichnis nicht gefunden.
Ursache:
Dieses Problem tritt meist deshalb auf, weil der Entitäts-ID ein Schrägstrich am Ende fehlt. Es kann aber auch darauf zurückzuführen sein, dass sich ein Teammitglied mit der falschen E-Mail-Adresse anzumelden versucht.
Lösung:
Stellen Sie sicher, dass Folgendes zutrifft:
- Das Teammitglied meldet sich mit der E-Mail-Adresse an, die in der Administrator-Konsole angezeigt wird.
- Ihre URLs für Entitäts-ID und ACS stimmen mit den Angaben in Ihrer Administrator-Konsole überein.
- Nach „saml“ wird in der Entitäts-ID Ihrer Unternehmensanwendung ein Schrägstrich ( / ) angezeigt: https://mycompanysso.azurewebsites.net/saml/
Anwendungsfehler
Fehler:
Wenn Sie der Anwendungsadministrator sind, können Sie auf die Diagnoseressourcen zugreifen.
Ursache:
Dieser Fehler tritt in der Regel auf, wenn die Variablen falsch aus der Konfigurationsdatei kopiert und eingefügt wurden oder aber einen Schrägstrich davor bzw. danach oder zusätzliche Zeichen enthalten.
Lösung:
Überprüfen Sie, dass die in Ihren Azure SSO-App-Service eingegebenen Variablen mit den Variablen in der Konfigurationsdatei, die Sie von der Dashlane-Administrator-Konsole heruntergeladen haben, übereinstimmen.
Gehen Sie auf portal.azure.com zu der von Ihnen erstellten Azure-App. Fügen Sie unter „Konfiguration“ die Variablen aus der soeben heruntergeladenen Konfigurationsdatei in die entsprechenden Werte in Azure ein.
Unbekannter Fehler
Fehler:
Bitte überprüfen Sie die Dashlane SSO-Verbindungsprotokolle oder kontaktieren Sie Ihren Systemadministrator.
Ursache:
Die häufigste Ursache für dieses Problem besteht darin, dass der Benutzer nicht über die erforderlichen Zugriffsrechte für die Dashlane SAML-Ap auf der SSO-Anbieter-Seite verfügt.
Lösung:
Vergewissern Sie sich, dass Sie den Benutzer zu Dashlane hinzugefügt und ihm die Zugriffsrechte für die Dashlane SSO-App auf Ihrem SSO-Anbieter erteilt haben.