This article is for organizations on a Dashlane Business plan.
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This article outlines errors that can occur during the SSO connector setup and their possible solutions.
Contents
Invalid SAML Signature
Error:
The SAML assertion from the identity provider has an invalid signature. If you're the administrator, please ensure you configure the SSO Connector to use the correct SAML certificate for the identity provider.
Cause:
The identity provider metadata and the SSO connector variable DASHLANE_SSO_SAML_IDP_CERTIFICATE are mismatched.
Sometimes this is caused by the XML file being opened in IE, which can add extraneous data when copying the page within IE.
Solution:
- Redownload the XML metadata from your identity provider.
- Open the XML file using Notepad or another plain text editor program.
- Paste the XML data into the Dashlane console.
https://console.dashlane.com > Settings > SAML SSO > Identity provider metadata
- You will not use the newly generated key, but you will need to click generate key to download the config file.
- Download the config file from the Dashlane console.
- In portal.azure.com, go to the Azure app you created. In the Configuration, re-paste the DASHLANE_SSO_SAML_IDP_CERTIFICATE= variable from the config file you just downloaded into the corresponding values in Azure.
- Click Save.
- Restart the app service.
- Rerun the test from the Dashlane console. You should see the following message:
Application with identifier was not found in the directory
Error:
Application with identifier was not found in the directory.
Cause:
This issue most commonly occurs because the Entity ID is missing the trailing slash but it can also arise if a team member tries to log in with the wrong email address.
Solution:
Ensure that:
- The team member is logging in with the email address that's displayed in the Team Admin console
- Your Entity ID and ACS URLs match those in your admin console
- A slash ( / ) appears after "saml" on the Entity ID on your Enterprise Application: https://mycompanysso.azurewebsites.net/saml/
Application Error
Error:
If you are the application administrator, you can access the diagnostic resources.
Cause:
This error typically occurs when the variables were copied/pasted incorrectly from the config file or include a leading or trailing space or extra characters.
Solution:
Verify that the variables entered in your Azure SSO app service match the variables in the config file you downloaded from the Dashlane Admin console.
In portal.azure.com, go to the Azure app you created. In the Configuration, re-paste the variables from the config file you just downloaded into the corresponding values in Azure.
Unknown Error
Error:
Please check Dashlane SSO connector logs or contact your system administrator.
Cause:
The most common cause of this error is that the user has does not have the rights to access the Dashlane SAML app on the SSO provider side.
Solution:
Ensure you've added the user to Dashlane and given them rights to access the Dashlane SAML app on your SSO provider.