Este artículo está dirigido a las organizaciones que tengan un plan Dashlane Business.
Actualice a Dashlane Business
En este artículo, se describen los errores que pueden producirse durante la configuración del conector del SSO y las posibles soluciones.
Firma de SAML no válida
Error:
La aserción SAML del proveedor de identidad no tiene una firma válida. Si usted es el administrador, asegúrese de haber configurado el conector del SSO, a fin de poder usar el certificado SAML correcto para el proveedor de identidad.
Causa:
Los metadatos del proveedor de identidad y la variable del conector del SSO DASHLANE_SSO_SAML_IDP_CERTIFICATE no coinciden.
A veces, esto se debe a que el archivo XML se abre en IE, lo que puede agregar datos extraños al copiar la página dentro de IE.
Solución:
- Vuelva a descargar los metadatos de XML desde su proveedor de identidad.
- Abra el archivo XML con Notepad o con otro editor de texto sin formato.
- Pegue los datos del XML en la consola de Dashlane.
https://console.dashlane.com > Opciones > SSO de SAML > Metadatos del proveedor de identidad
- No usará la nueva clave generada, pero deberá hacer clic en clave generada para descargar el archivo de configuración.
- Descargue el archivo de configuración desde la consola de Dashlane.
- En portal.azure.com, vaya a la aplicación de Azure que creó. En la Configuración, vuelva a pegar la variable DASHLANE_SSO_SAML_IDP_CERTIFICATE= del archivo de configuración que descargó en los valores correspondientes, en Azure.
- Haga clic en Guardar.
- Reinicie el servicio de la aplicación.
- Vuelva a ejecutar la prueba desde la consola de Dashlane. Debe ver el siguiente mensaje:
No se encontró la aplicación con identificador en el directorio
Error:
No se encontró la aplicación con identificador en el directorio.
Causa:
Normalmente, el problema se produce porque al ID de entidad le falta la barra diagonal final, pero también puede ocurrir si un miembro del equipo intenta ingresar con una dirección de correo electrónico incorrecta.
Solución:
Asegúrese de lo siguiente:
- El miembro del equipo está ingresando con la dirección de correo electrónico que aparece en la consola de administración.
- Las URL del ID de entidad y de ACS coinciden con las que figuran en su consola de administración.
- Aparece una barra ( / ) después de "saml" en el ID de entidad de su aplicación empresarial: https://mycompanysso.azurewebsites.net/saml/.
Error de la aplicación
Error:
Si usted es el administrador de la aplicación, puede acceder a los recursos de diagnóstico.
Causa:
Por lo general, este error ocurre cuando las variables se copiaron/pegaron incorrectamente desde el archivo de configuración o cuando incluyen un espacio o caracteres adicionales al principio o al final.
Solución:
Verifique que las variables introducidas en su servicio de aplicación del SSO de Azure coincidan con las variables del archivo de configuración que descargó de la consola de administración de Dashlane.
En portal.azure.com, vaya a la aplicación de Azure que creó. En Configuración, vuelva a pegar las variables del archivo de configuración que descargó en los valores correspondientes de Azure.
Error desconocido
Error:
Consulte los registros del conector del SSO de Dashlane o comuníquese con su administrador del sistema.
Causa:
Por lo general, este error ocurre porque el usuario no tiene los derechos para acceder a la aplicación SAML de Dashlane en el proveedor del SSO.
Solución:
Asegúrese de que agregó el usuario a Dashlane y de que le otorgó los derechos para acceder a la aplicación de SAML de Dashlane en su proveedor del SSO.