Cet article s'adresse aux organisations utilisant un forfait Dashlane Business.
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Cet article énumère les erreurs possibles lors de la configuration du connecteur SSO ainsi que les solutions possibles pour les résoudre.
Signature SAML non valide
Erreur :
L'assertion SAML provenant du fournisseur d'identité possède une signature non valide. Si vous êtes l'administrateur, veillez à configurer le connecteur SSO de façon à pouvoir utiliser le bon certificat SAML pour le fournisseur d'identité.
Cause :
Les métadonnées du fournisseur d'identité et la variable du connecteur SSO DASHLANE_SSO_SAML_IDP_CERTIFICATE ne correspondent pas.
Cela provient parfois du fait que le fichier XML est ouvert dans IE, ce qui peut ajouter des données superflues lorsque l'on copie la page dans IE.
Solution :
- Téléchargez à nouveau les métadonnées XML à partir de votre fournisseur d'identité.
- Ouvrez le fichier XML à l'aide du bloc-notes ou d'un autre éditeur de texte.
- Collez les données XML dans la console de Dashlane.
https://console.dashlane.com > Paramètres > SAML SSO > Métadonnées du fournisseur d'identité
- Vous n'utiliserez pas la clé qui vient d'être générée, mais vous devrez cliquer sur Générer une clé pour télécharger le fichier de configuration.
- Téléchargez le fichier de configuration depuis la console d'administration.
- Dans portal.azure.com, rendez-vous dans l'application Azure que vous avez créée. Dans Configuration, collez à nouveau la variable DASHLANE_SSO_SAML_IDP_CERTIFICATE= à partir du fichier de configuration que vous venez de télécharger dans les valeurs correspondantes dans Azure.
- Cliquez sur Enregistrer.
- Redémarrez le service de l'application.
- Exécutez à nouveau le test à partir de la console Dashlane. Vous devriez voir le message suivant :
L'application avec l'identifiant est introuvable dans le répertoire
Erreur :
L'application avec l'identifiant est introuvable dans le répertoire.
Cause :
Le plus souvent, ce problème est dû à une barre oblique manquante à la fin de l'ID d'entité, mais il peut aussi se produire si un membre du forfait tente de se connecter avec la mauvaise adresse e-mail.
Solution :
Vérifiez que :
- Le membre du forfait utilise l'adresse de connexion affichée dans la console d'administration
- Les URL ACS et l'ID d'entité correspondent à ceux de votre console d'administration
- Une barre oblique (/) apparaît après « saml » dans l'ID d'entité de votre application d'entreprise https://ssodemonentreprise.azurewebsites.net/saml/
Erreur de l'application
Erreur :
Si vous êtes l'administrateur de l'application, vous pouvez accéder aux ressources de diagnostic.
Cause :
Ce problème survient généralement suite à une erreur lors du copier-coller des variables depuis le fichier de configuration, à des espaces superflues avant ou après une variable, ou à l'introduction de caractères superflus.
Solution :
Vérifiez que les variables saisies dans votre service d'application Azure SSO correspondent à celles du fichier de configuration que vous avez téléchargé depuis la console d'administration Dashlane.
Dans portal.azure.com, rendez-vous dans l'application Azure que vous avez créée, puis, dans Configuration, collez à nouveau les valeurs du fichier de configuration que vous venez de télécharger dans les valeurs correspondantes dans Azure.
Erreur inconnue
Erreur :
Vérifiez les journaux de votre connecteur SSO Dashlane ou contactez votre administrateur système.
Cause :
Le plus souvent, cette erreur survient quand un utilisateur n'est pas autorisé à accéder à l'application Dashlane SAML du côté du fournisseur de SSO.
Solution :
Vérifiez que vous avez ajouté l'utilisateur à Dashlane et qu'il est bien autorisé à accéder à l'application Dashlane SAML du côté de votre fournisseur de SSO.